Hello Guest  /  Join  /  Sign In  /  Get Desura

Omegalodon is a third-person multiplayer action game where players compete by attacking/defending the city. The Red Team is comprised of police and soldiers armed with an array of military vehicles and explosive weaponry. The Green Team is comprised of Omegalodon, a 100-foot shark monster, and the Enviros, equipped with a healing beam. The game plays like a backward tower-defense game, but with free-roaming capability and fast-paced, realtime action.

Omegalodon's objective is a nuclear containment dome at the city center. The round will end if it is destroyed, the timer reaches zero, or if Omegalodon dies.

Features:

- Fully destructible environments
- Dozens of drivable vehicles including helicopters, cargo ships, and jets
- 30-minute round-based multiplayer
- Dozens of simultaneous players
- Story elements will full voice acting
- Nine square miles of open world, spanning islands and cityscapes
- A colorful, retro aesthetic

Can't join Servers
by member
  Posts Date
Thread Options 1 2
Noooch Mar 24 2012, 9:12am Anchor
Noooch

I bought the game a few days ago. By the way well doen on making such an amazing game. But recently I have found that I cant join any servers. It just sits on the connecting screen and then does nothing until I click off it.

Any help will be appreciated.

Cheers
*Noooch

NorthOfEarth Mar 24 2012, 5:20pm Anchor
NorthOfEarth

If you are in Windows, run the game as an administrator.

Otherwise, run the game windowed and you might see a popup asking to 'allow connection.' Make sure both boxes are checked and click Allow.

Noooch Mar 25 2012, 5:03am Anchor
Noooch

I have done both and still nothing. I was able to join one of my mates who was hosting but it seems i cant join anyone else. Was working not long ago. Then when I tried to play with a couple of mates I couldnt join the server. We had to keep swapping hosts until I eventually joined one. It seems I can only join a select group of servers. my mates are having no such trouble

NorthOfEarth Mar 25 2012, 6:06pm Anchor
NorthOfEarth

1. Are you running version 1.3.1?

2. Have you ever been able to join any other games?

3. What kind of internet connection do you have?

4. Try hosting a server and pressing TAB to see your Public IP. The number after the colon is your external port.

5. Try forwarding that port in your router settings. (You may have to look up instructions as each one is different)

It seems you may have an unusual setup, which can occur in some parts of the world with certain ISPs. Let me know as much info as possible and I'll try to fix it in the next patch.

Noooch Mar 26 2012, 1:50am Anchor
Noooch

1. Yes

2. Yes

3. ADSL2 12 Meg a second down speed

4. Tried that no one can join

5. Did that, except every time I host a server the port changes

1 Of my mates whom I want to play with is having the exact same problem as I am having. Except occasionnally he can join a server. I have been able to join some but the ones I can join my friends cant and visa versa.

NorthOfEarth Mar 26 2012, 2:52pm Anchor
NorthOfEarth

Are they in the same building as you?

Noooch Mar 26 2012, 10:34pm Anchor
Noooch

some are across the other side of the country and others are closer by. But no one is in the same building

NorthOfEarth Mar 27 2012, 1:30am Anchor
NorthOfEarth

I'm still investigating this, and I assume 1.4 hasn't fixed it. The fact that your port keeps changing is unusual. I experienced that only while testing the game with a 3G connection. I'm going to need as much info about your setup as possible to troubleshoot this. Type of router, how many connected devices, public IP, etc. PM me for privacy's sake.

luece Apr 7 2012, 6:57pm Anchor
luece

i have had the problem of not joining so i exit it through task manager and when it starts up the server is gone so im guessing that you join when they end the server, this might just be me

an error i got is that i am already in a server but i just have 1 program of the game open

egpheel Jun 10 2012, 9:10pm Anchor
egpheel

I have the same problem, and my ports keep changing aswell :(

HJK148 Jun 24 2012, 11:05am Anchor
HJK148

I have the same problem, lucky for me I got the demo first before buying it, or I'd have bought a game that I couldn't play. I hope you find out what it is, the game looks really fun.

bjb126 Sep 9 2012, 2:43pm Anchor
bjb126

*Bump* I just bought this game like 20 minutes ago and I can't join any server :(
Just another waste of money..

NorthOfEarth Sep 10 2012, 2:26am Anchor
NorthOfEarth

Try the following:

1. Run the game as Administrator.

2. When attempting to join, Alt-Tab out and see if there is a Windows Firewall popup. If so, check both boxes and click Allow.

3. Look into your router settings and forward port 25565.

4. Contact the server admin and Direct Connect using the IP address.

This error is due to server admins not correctly forwarding their ports, as is specified in the ReadMe.

Shingyboy Oct 14 2012, 4:08pm Anchor
Shingyboy

I am getting similar results, being to like maybe join a server but mostly I can't

NorthOfEarth Oct 14 2012, 8:44pm Anchor
NorthOfEarth

Did you try the steps above?

TrueGetn92 Nov 4 2012, 4:03pm Anchor
TrueGetn92

How do you run the game as "Administrator"?

NorthOfEarth Nov 5 2012, 1:16am Anchor
NorthOfEarth

In Windows go to

C:\Program Files (x86)\Desura\Common\omegalodon

Right-click Omegalodon_Win and choose Run as administrator.

Fadel12321 Jan 19 2013, 4:41pm Anchor
Fadel12321

It's impossible for me to run Omeladon as administrator :/ whenever I do it brings up a box and it has the names of the programs that are causing the errors. I'm NO technical badass here, but I think the demo might have something screwed over with it. I trust the game works, because Nerd cubed played it, just please help! :/ I don't want to buy the game unless I know it works.

NorthOfEarth Jan 19 2013, 9:06pm Anchor
NorthOfEarth

Post a screenshot of the error.

olle1337 Mar 8 2013, 12:50pm Anchor
olle1337

I am also having problems connecting to servers. I have tried the following:
1. Port-forwarding port 25565 and the port that showed up when I started a game.
2. Allowed the game in both Zonealarm and Windows Firewall
3. Run as administrator
4. Different graphics-settings
Nothing works, I am living in Sweden so it may be that the server is too far away in USA or so.
Going to reinstall, will write here when I am done testing that.

Nope, no luck with reinstall. Checked some file called output_log, said something about server using NAT and it failed.

Jomskylark Mar 19 2013, 10:32pm Anchor
Jomskylark

Can you test if the game works on other computers, ie. a library computer? I'd be interested to know if you're getting blocked due to a region issue as opposed to software issue. I do know a lot of players are US-based.

NorthOfEarth Mar 20 2013, 6:01pm Anchor
NorthOfEarth

This is a region issue. Some ISPs do not provide what's called "NAT Punchthrough," which enables connections between DNS systems. Some countries employ their own DNS, and this is a symptom. Larger games overcome this by providing their own punchthrough mechanism with servers in each region, but this is not possible for my small company.

Han1014 Apr 11 2013, 4:06pm Anchor
Han1014

Whenever I try to connect, the the game just crashes after minute or to of trying to connect.
and yes I do have administrator mode on, and Both boxes checked in firewall.

I'm in a university dorm, so port forwarding isn't really an option

NorthOfEarth Apr 11 2013, 5:24pm Anchor
NorthOfEarth

Are you using the latest version of the game? You will be kicked if you try to join a server with a different version.

reznik9 Jun 13 2013, 8:13pm Anchor
reznik9

how to downgrade it?i have  1.4,

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.