Hello Guest  /  Join  /  Sign In  /  Get Desura

Conquest of Elysium 3 is an old school fantasy strategy game. You explore your surroundings conquer locations that provides the resources you need. Resources needed vary much depending on what character you are, e.g. the high priestess need places where she can gather human sacrifices, the baron needs places where tax can be collected and where iron can be mined. These resources can then be used for magic rituals and troop recruitments. The main differentiator for this game is the amount of features and special abilities that can be used.

The game can be played on Windows, Linux (x86 and raspberry pi) and Mac OSX (intel and powerpc).

The old bug post
by member
  Posts Date
Thread Options 1 2 3 4 5 6 7 8 ... 16
Edirr Feb 20 2012, 1:18am Anchor
Edirr

Okay, somebody was asking about where and how to report bugs. Post the reports here. I'll sort the lot out. When Johan manages to sort out the moderator permissions and other similar things, I'll be able to organize this better, but use this thread for the time being.

Edit: This post is from when there was no seperate bug forum. Now there is, so please feel free to start seperate threads for the new bugs you find. Having everything in the same thread can get a bit unwieldy. /Johan

Edited by: jk.illwinter

Admiral_Aorta Feb 20 2012, 1:27am Anchor
Admiral_Aorta

I'm not sure if it's quite a bug, but the music doesn't seem to loop. When a new season starts you'll get new music playing but then it stops and you don't get any more until it changes again. I also noticed there's still a few coe2 sprites hanging around, some of the buildings as well as a few units like the ape.

carltonbauheimer Feb 20 2012, 1:34am Anchor
carltonbauheimer

This might have been reported somewhere else, but just in case...

A bug that a group of us ran into on a multiplayer game.  It was on a map that GP set up to where everybody could team up on the highest level AI senator.  There were five players and two AI, I think.  Cluster start.  The game was going fine until about the first winter.  We all stopped collecting income, even if we showed a positive income.  And it wasn't just gold, but other resources, too.  We played a few turns, into spring or summer I think, and even though it showed our income increased, the amount of gold/resources we had never changed. 

We stopped playing and then started a new game, same map, same players, NOT cluster start, and it was fine.

Edirr Feb 20 2012, 1:40am Anchor
Edirr

Admiral_Aorta, the music doesn't loop automatically. There are some things that trigger a new tune, and if you go to e.g. the recruitment menu or somewhere else for a long time, it may stop but will start up again when you go to the main map.

carltonbauheimer,
Definitely hasn't been seen anywhere else. I expect that most of the bugs to be discovered are in the network MP side, since the test crew had a hard time organizing MP games due to time zone scatter. I'll notify Johan about that, though I expect that he will be reading this forum as well.

jk.illwinter Feb 20 2012, 1:43am Anchor
jk.illwinter

I pinned this thread, so it's now the official bug reporting thread.

Strabonic Feb 20 2012, 2:04am Anchor
Strabonic
O
N
L
I
N
E

Druid's Major Summoning ability looks enabled (black, not gray), but does not work in brigand lair.

Cougar_DK Feb 20 2012, 3:05am Anchor
Cougar_DK

I can't make capital letters in game, ie, its not possible to write capital letter for names and filenames.

I'm running danish windows 7 32 bit and will test it out on my other gaming rigs when I get home :D 

Thanks for a great game.
Mark

Edirr Feb 20 2012, 3:07am Anchor
Edirr

That particularly annoying bug sometimes happens in Dominons 3 too. Just shut down the game and restart and it should go away. It happens to me intermittently too and when it does, the capital letter keyboard shortcuts don't work either. Nobody has managed to track down the reason yet.

kagata Feb 20 2012, 3:09am Anchor
kagata

If I turn on the option to automatically switch to the next commander when the current one runs out of action points, but I use a ritual and run out of action points, it doesn't automatically switch to the next commander.

Darizzo Feb 20 2012, 3:18am Anchor
Darizzo

Im on windows. After install, when i open the program, it imediately closes the window with a (not responding). Get a " coe3.exe has stopped working, a problem caused the program to stop working correctly......" . Then after everything closes i get a "coe3.exe was closed, data execution prevention has closed coe3.exe"

Cougar_DK Feb 20 2012, 3:19am Anchor
Cougar_DK

Thanks Edirr. I will try that out!

jk.illwinter Feb 20 2012, 4:02am Anchor
jk.illwinter
Darizzo wrote:Im on windows. After install, when i open the program, it imediately closes the window with a (not responding). Get a " coe3.exe has stopped working, a problem caused the program to stop working correctly......" . Then after everything closes i get a "coe3.exe was closed, data execution prevention has closed coe3.exe"

Ok, let's see if the event log says what went wrong. Here's how to open the event viewer:

a. Click on start.
b. In the search box type eventvwr.msc and press enter.
c. Now click on Application under Event Viewer (local).
d. Now look for event log on right hand side of the Event Viewer windows.

Do that right after CoE3 has crashed and see if you can find that event in there. It should be there.

Edirr Feb 20 2012, 4:05am Anchor
Edirr
Darizzo wrote:Im on windows. After install, when i open the program, it imediately closes the window with a (not responding). Get a " coe3.exe has stopped working, a problem caused the program to stop working correctly......" . Then after everything closes i get a "coe3.exe was closed, data execution prevention has closed coe3.exe"

Do what Johan said. You probably have Data Execution Prevention settings enabled from the Windows system properties. You can turn that off and see if it helps any. Right click on Computer, select properties and go to Advanced Settings from the left hand panel. Should be in there somewhere.

BesucherXia Feb 20 2012, 5:44am Anchor
BesucherXia

Am I the only one meeting a display bug? my whole background for battlefield and "town interface" were displayed in black and I can hardly find anything else except the units stand in line.

My system is a win7-64bit with Nvidia GTX460,  driver version 285.62(didnt find newer one)

Edited by: BesucherXia

Kamamura Feb 20 2012, 6:24am Anchor
Kamamura

Windows 7 64bit Alt_TAB does not work - I get black screen, and that's it. The only way out is killing the game process. Also (minor), the screen asking for serial key should have the Alt+Enter shortcut for switching to window mentioned, so that the serial key can be copy-pasted easily.

Aspire 7750G notebook with Radeon 6850M card.

Edited by: Kamamura

profanicus Feb 20 2012, 7:15am Anchor
profanicus
Kamamura wrote:Windows 7 64bit Alt_TAB does not work - I get black screen, and that's it.

Working ok here. AMD Radeon with Catalyst 12.1.

Kamamura Feb 20 2012, 7:27am Anchor
Kamamura

Scouts are not commanders and cannot move around the map on their own.

Cougar_DK Feb 20 2012, 7:59am Anchor
Cougar_DK
Kamamura wrote:Windows 7 64bit Alt_TAB does not work - I get black screen, and that's it. The only way out is killing the game process. Also (minor), the screen asking for serial key should have the Alt+Enter shortcut for switching to window mentioned, so that the serial key can be copy-pasted easily.

I saw this too, on my work pc with a ATI Radeon HD 3400 running Win 7 32 bit. Will try it tomorrow at my primary gaming rig.

AngelSong Feb 20 2012, 8:13am Anchor
AngelSong
Kamamura wrote:Scouts are not commanders and cannot move around the map on their own.

Scouts is soldier,no commander.

Larzm42 Feb 20 2012, 1:11pm Anchor
Larzm42

I've got these tiles starting to show up in the map. Any ideas? I did just move where the save games are stored, maybe some kind of cheat protection?

Techymancer Feb 20 2012, 1:35pm Anchor
Techymancer

On mac, running a multiplayer server, a disconnecting player causes a broken pipe error, and subsequently crashes the server. Not sure if it happens in game but certainly happens in the pre-game setup.

Darizzo Feb 20 2012, 2:04pm Anchor
Darizzo
jk.illwinter wrote:
Darizzo wrote:Im on windows. After install, when i open the program, it imediately closes the window with a (not responding). Get a " coe3.exe has stopped working, a problem caused the program to stop working correctly......" . Then after everything closes i get a "coe3.exe was closed, data execution prevention has closed coe3.exe"

Ok, let's see if the event log says what went wrong. Here's how to open the event viewer:

a. Click on start.
b. In the search box type eventvwr.msc and press enter.
c. Now click on Application under Event Viewer (local).
d. Now look for event log on right hand side of the Event Viewer windows.

Do that right after CoE3 has crashed and see if you can find that event in there. It should be there.


Ok just did what you asked...this followed:

Log Name:      Application
Source:        Application Error
Date:          2/20/2012 10:45:36 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A

Description:
Faulting application coe3.exe, version 0.0.0.0, time stamp 0x4f391aac, faulting module unknown, version 0.0.0.0, time stamp 0x00000000, exception code 0xc0000005, fault offset 0x08fa4bc0, process id 0x13a4, application start time 0x01ccefffd501b66f.

Edirr wrote:
Do what Johan said. You probably have Data Execution Prevention settings enabled from the Windows system properties. You can turn that off and see if it helps any. Right click on Computer, select properties and go to Advanced Settings from the left hand panel. Should be in there somewhere.

Did that first...aperently i cant turn data execution prevention off for this program

Edited by: Darizzo

Edirr Feb 20 2012, 2:24pm Anchor
Edirr
Larzm42 wrote:I've got these tiles starting to show up in the map. Any ideas? I did just move where the save games are stored, maybe some kind of cheat protection?

Do you have a savegame of that? If you do, send that to info at illwinter dot com for analysis along with that attached screenshot. We saw that happen a few times in the beta, but could not reliably reproduce it. There must be some kind of junk graphics somewhere in the game files that cause that to happen. That bugged square should be a mountain.

drwhat Feb 20 2012, 2:49pm Anchor
drwhat

Attacking a catapult in a town, it was somehow able to fire and reload and fire again four or five times before I got a round. The description of the Boulder attack is "only usable once every two rounds".

Needless to say, it went poorly for me.

Edited by: drwhat

Edirr Feb 20 2012, 2:52pm Anchor
Edirr

Read the manual. The answers to your question are in chapter 6, namely the section on combat sequence and the phase on siege weapons.

A quick reminder:

1) Prebattle effects
2) Assassination
3) Siege weapons
4) Regular combat until one side wins
4.1) Back ranks
4.2) Mid ranks
4.3) Front ranks
4.4) WHILE  (sides >1) GOTO 4.1

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.